博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
a letter and a number
阅读量:5967 次
发布时间:2019-06-19

本文共 772 字,大约阅读时间需要 2 分钟。

 

a letter and a number

时间限制:
3000 ms  |  内存限制:
65535 KB
难度:
1
 
描述
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
 
输入
On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
输出
for each case, you should the result of y+f(x) on a line
样例输入
6R 1P 2G 3r 1p 2g 3
样例输出
191810-17-14-4
代码如下:
#include<stdio.h>
#include<string.h>
int main()
{
 int n,m;  
 char c;
 scanf("%d",&n); 
 while(n--)
 { 
  getchar();
  scanf("%c",&c);
  scanf("%d",&m);
  if(c>='a'&&c<='z')
   printf("%d\n",96-c+m);
  if(c>='A'&&c<='Z')
   printf("%d\n",c-64+m);
 }
 return 0;
}

 

转载于:https://www.cnblogs.com/wangyouxuan/p/3223937.html

你可能感兴趣的文章
python基础学习笔记(九)
查看>>
BaaS API 设计规范
查看>>
bootloader功能介绍/时钟初始化设置/串口工作原理/内存工作原理/NandFlash工作原理...
查看>>
iOS开发UI篇—Quartz2D使用(矩阵操作)
查看>>
C++ 构造函数与析构函数
查看>>
定时压缩log日志文件
查看>>
Tomcat的结构概述
查看>>
轻松八句话 教会你完全搞定MySQL数据库(基础)
查看>>
UIImagePickerController选择图片发送后旋转90度的问题
查看>>
常用excel函数 vlookup,concatenate,& 的使用
查看>>
MySql多表
查看>>
数据创建表 修改列 新增列
查看>>
PHP 服务器变量 $_SERVER(转)
查看>>
Linux基础 -- vim编辑器3 -- 查找和替换
查看>>
openssh-server (>= 1:6.6p1-2ubuntu1) but it is not going to be installed
查看>>
Apache Shiro SessionManager配置详解.
查看>>
Elasticsearch的Watcher插件
查看>>
译 | 像使用一台主机一样管理集群
查看>>
PostgreSQL数值类型--浮点类型和序列
查看>>
Java栈与堆详解
查看>>